#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(?:Phone:).*(?:Phone:)([\s?+\d\w-()]*?\n)"
Local $sString = "Name: Joe B" & @CRLF & _
"Phone: 23323-43434-332321" & @CRLF & _
"Some text" & @CRLF & _
"Some more text" & @CRLF & _
"Phone: +(91) 123-456-2343" & @CRLF & _
"Some more text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")