import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:Phone:).*(?:Phone:)([\\s?+\\d\\w-()]*?\\n)";
final String string = "Name: Joe B\n"
+ "Phone: 23323-43434-332321\n"
+ "Some text\n"
+ "Some more text\n"
+ "Phone: +(91) 123-456-2343\n"
+ "Some more text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}