using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?:Phone:).*(?:Phone:)([\s?+\d\w-()]*?\n)";
string input = @"Name: Joe B
Phone: 23323-43434-332321
Some text
Some more text
Phone: +(91) 123-456-2343
Some more text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}