re = /(?s)(?:Phone:).*(?:Phone:)([\s?+\d\w-()]*?\n)/m
str = 'Name: Joe B
Phone: 23323-43434-332321
Some text
Some more text
Phone: +(91) 123-456-2343
Some more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end