const regex = /(?s)(?:Phone:).*(?:Phone:)([\s?+\d\w-()]*?\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?:Phone:).*(?:Phone:)([\\s?+\\d\\w-()]*?\\n)', 'gm')
const str = `Name: Joe B
Phone: 23323-43434-332321
Some text
Some more text
Phone: +(91) 123-456-2343
Some more text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}