$re = '/(?s)(?:Phone:).*(?:Phone:)([\s?+\d\w-()]*?\n)/m';
$str = 'Name: Joe B
Phone: 23323-43434-332321
Some text
Some more text
Phone: +(91) 123-456-2343
Some more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);