using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a(r|i|ir|ri|irr|rri|rr)(ba|b|ab)
";
string input = @"ariba
airba
arba
arib
airb
arriba
arrba
airrba
airab
ariab
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}