$re = '/a(r|i|ir|ri|irr|rri|rr)(ba|b|ab)
/m';
$str = 'ariba
airba
arba
arib
airb
arriba
arrba
airrba
airab
ariab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);