re = /a(r|i|ir|ri|irr|rri|rr)(ba|b|ab)
/m
str = 'ariba
airba
arba
arib
airb
arriba
arrba
airrba
airab
ariab
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end