package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a(r|i|ir|ri|irr|rri|rr)(ba|b|ab)
`)
var str = `ariba
airba
arba
arib
airb
arriba
arrba
airrba
airab
ariab
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}