import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a(r|i|ir|ri|irr|rri|rr)(ba|b|ab)\n";
final String string = "ariba\n"
+ "airba\n"
+ "arba\n"
+ "arib\n"
+ "airb\n"
+ "arriba\n"
+ "arrba\n"
+ "airrba\n"
+ "airab\n"
+ "ariab\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}