#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*([A-Z]{3})\s*=\s*([0-9.]+)\s*([A-Z]{3})\s*$"
Local $sString = "USD = 6.4CNY " & @CRLF & _
"CNY = 0.13 EUR" & @CRLF & _
" EUR = 0.87 GBP " & @CRLF & _
" GBP = 89.4 INR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")