re = /^\s*([A-Z]{3})\s*=\s*([0-9.]+)\s*([A-Z]{3})\s*$/m
str = 'USD = 6.4CNY
CNY = 0.13 EUR
EUR = 0.87 GBP
GBP = 89.4 INR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end