use strict;
my $str = 'USD = 6.4CNY
CNY = 0.13 EUR
EUR = 0.87 GBP
GBP = 89.4 INR';
my $regex = qr/^\s*([A-Z]{3})\s*=\s*([0-9.]+)\s*([A-Z]{3})\s*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}