// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*([A-Z]{3})\s*=\s*([0-9.]+)\s*([A-Z]{3})\s*$").unwrap();
let string = "USD = 6.4CNY
CNY = 0.13 EUR
EUR = 0.87 GBP
GBP = 89.4 INR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}