package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*([A-Z]{3})\s*=\s*([0-9.]+)\s*([A-Z]{3})\s*$`)
var str = `USD = 6.4CNY
CNY = 0.13 EUR
EUR = 0.87 GBP
GBP = 89.4 INR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}