#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Z][A-Z0-9]*(?:_[A-Z0-9]+)+\b"
Local $sString = ""ID_RED", "NO_ENTRY_PERMITTED", "THIS_IS4YOU_ALL". I do not want to catch "THINKING__NO" or "4YOU_AND_ME"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")