import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z][A-Z0-9]*(?:_[A-Z0-9]+)+\\b";
final String string = "\"ID_RED\", \"NO_ENTRY_PERMITTED\", \"THIS_IS4YOU_ALL\". I do not want to catch \"THINKING__NO\" or \"4YOU_AND_ME\".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}