using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z][A-Z0-9]*(?:_[A-Z0-9]+)+\b";
string input = @"""ID_RED"", ""NO_ENTRY_PERMITTED"", ""THIS_IS4YOU_ALL"". I do not want to catch ""THINKING__NO"" or ""4YOU_AND_ME"".";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}