$re = '/\b[A-Z][A-Z0-9]*(?:_[A-Z0-9]+)+\b/m';
$str = '"ID_RED", "NO_ENTRY_PERMITTED", "THIS_IS4YOU_ALL". I do not want to catch "THINKING__NO" or "4YOU_AND_ME".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);