const regex = /\b[A-Z][A-Z0-9]*(?:_[A-Z0-9]+)+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z][A-Z0-9]*(?:_[A-Z0-9]+)+\\b', 'gm')
const str = `"ID_RED", "NO_ENTRY_PERMITTED", "THIS_IS4YOU_ALL". I do not want to catch "THINKING__NO" or "4YOU_AND_ME".`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}