package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z][A-Z0-9]*(?:_[A-Z0-9]+)+\b`)
var str = `"ID_RED", "NO_ENTRY_PERMITTED", "THIS_IS4YOU_ALL". I do not want to catch "THINKING__NO" or "4YOU_AND_ME".`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}