using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:'s)?[^\p{L}\-\d_]+|\.+$";
string substitution = @"-";
string input = @"Infographic phishing's awareness and $prevention (updated).+!@=¨$'^^;,:";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}