package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:'s)?[^\p{L}\-\d_]+|\.+$`)
var str = `Infographic phishing's awareness and $prevention (updated).+!@=¨$'^^;,:`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}