re = /(?:'s)?[^\p{L}\-\d_]+|\.+$/m
str = 'Infographic phishing\'s awareness and $prevention (updated).+!@=¨$\'^^;,:'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result