const regex = /(?:'s)?[^\p{L}\-\d_]+|\.+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\'s)?[^\\p{L}\\-\\d_]+|\\.+$', 'gm')
const str = `Infographic phishing's awareness and \$prevention (updated).+!@=¨\$'^^;,:`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);