import Foundation
let pattern = #"(?:'s)?[^\p{L}\-\d_]+|\.+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Infographic phishing's awareness and $prevention (updated).+!@=¨$'^^;,:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)