const regex = /^[^:\s]++(?!:)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^:\\s]++(?!:)', 'mg')
const str = `1 : A
2 : B
3 : C
1
2
3
1:A
11:A`;
const subst = `Line:$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);