use strict;
my $str = '1 : A
2 : B
3 : C
1
2
3
1:A
11:A';
my $regex = qr/^[^:\s]++(?!:)/mp;
my $subst = 'Line:$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";