import Foundation
let pattern = #"^[^:\s]++(?!:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 : A
2 : B
3 : C
1
2
3
1:A
11:A
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Line:$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)