import re
regex = re.compile(r"^[^:\s]++(?!:)", flags=re.MULTILINE)
test_str = ("1 : A\n"
"2 : B\n"
"3 : C\n"
"1\n"
"2\n"
"3\n"
"1:A\n"
"11:A")
subst = "Line:$0"
result = regex.sub(subst, test_str)
if result:
print(result)