# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*[()]\s*/\n/gm;t' <<< "flow gavage(ZAB_B2_COCUM) BS
flowWithoutSpace (WitoutUnderscore) BS"