using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*[()]\s*";
string substitution = @"\n";
string input = @"flow gavage(ZAB_B2_COCUM) BS
flowWithoutSpace (WitoutUnderscore) BS";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}