import Foundation
let pattern = #"\s*[()]\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
flow gavage(ZAB_B2_COCUM) BS
flowWithoutSpace (WitoutUnderscore) BS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)