$re = '/\s*[()]\s*/m';
$str = 'flow gavage(ZAB_B2_COCUM) BS
flowWithoutSpace (WitoutUnderscore) BS';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;