use strict;
my $str = 'flow gavage(ZAB_B2_COCUM) BS
flowWithoutSpace (WitoutUnderscore) BS';
my $regex = qr/\s*[()]\s*/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";