using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\d_-]*[a-zA-Z][-\w]*$";
string input = @"ecK3EnyGD8o
1s3get2-3ds
4bc2qfs2wrf
28yq389gfwg
3oyh8pw489p
abcdefghijk
abcde-fghi_jk
12345678910
18974107892351240891751928347819234
Stack Overflow
kjsad;kflj;klasdfkjalk;sdfjlkas
!&$@#)&&()%&*(#@$&(";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}