package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\d_-]*[a-zA-Z][-\w]*$`)
var str = `ecK3EnyGD8o
1s3get2-3ds
4bc2qfs2wrf
28yq389gfwg
3oyh8pw489p
abcdefghijk
abcde-fghi_jk
12345678910
18974107892351240891751928347819234
Stack Overflow
kjsad;kflj;klasdfkjalk;sdfjlkas
!&$@#)&&()%&*(#@$&(`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}