$re = '/^[\d_-]*[a-zA-Z][-\w]*$/m';
$str = 'ecK3EnyGD8o
1s3get2-3ds
4bc2qfs2wrf
28yq389gfwg
3oyh8pw489p
abcdefghijk
abcde-fghi_jk
12345678910
18974107892351240891751928347819234
Stack Overflow
kjsad;kflj;klasdfkjalk;sdfjlkas
!&$@#)&&()%&*(#@$&(';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);