#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:placebo\s+\S+|\S+\s+placebo)$"
Local $sString = "Placebo Calcitriol" & @CRLF & _
"Placebo Alendronate" & @CRLF & _
"Placebo version of rgp120/HIV-1MN" & @CRLF & _
"Placebo version of rgp120/HIV-1SF2" & @CRLF & _
"Gemcitabine with Placebo" & @CRLF & _
"Tretinoin 0.1% cream or placebo" & @CRLF & _
"Doxycycline (200mg/day) or Placebo" & @CRLF & _
"PAL-40 Placebo" & @CRLF & _
"abciximab placebo; reteplase placebo, abciximab " & @CRLF & _
"Valsartan placebo + nateglinide placebo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")