import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:placebo\\s+\\S+|\\S+\\s+placebo)$";
final String string = "Placebo Calcitriol\n"
+ "Placebo Alendronate\n"
+ "Placebo version of rgp120/HIV-1MN\n"
+ "Placebo version of rgp120/HIV-1SF2\n"
+ "Gemcitabine with Placebo\n"
+ "Tretinoin 0.1% cream or placebo\n"
+ "Doxycycline (200mg/day) or Placebo\n"
+ "PAL-40 Placebo\n"
+ "abciximab placebo; reteplase placebo, abciximab \n"
+ "Valsartan placebo + nateglinide placebo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}