import Foundation
let pattern = #"^(?:placebo\s+\S+|\S+\s+placebo)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Placebo Calcitriol
Placebo Alendronate
Placebo version of rgp120/HIV-1MN
Placebo version of rgp120/HIV-1SF2
Gemcitabine with Placebo
Tretinoin 0.1% cream or placebo
Doxycycline (200mg/day) or Placebo
PAL-40 Placebo
abciximab placebo; reteplase placebo, abciximab
Valsartan placebo + nateglinide placebo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)