use strict;
my $str = 'Placebo Calcitriol
Placebo Alendronate
Placebo version of rgp120/HIV-1MN
Placebo version of rgp120/HIV-1SF2
Gemcitabine with Placebo
Tretinoin 0.1% cream or placebo
Doxycycline (200mg/day) or Placebo
PAL-40 Placebo
abciximab placebo; reteplase placebo, abciximab
Valsartan placebo + nateglinide placebo';
my $regex = qr/^(?:placebo\s+\S+|\S+\s+placebo)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}