using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:placebo\s+\S+|\S+\s+placebo)$";
string input = @"Placebo Calcitriol
Placebo Alendronate
Placebo version of rgp120/HIV-1MN
Placebo version of rgp120/HIV-1SF2
Gemcitabine with Placebo
Tretinoin 0.1% cream or placebo
Doxycycline (200mg/day) or Placebo
PAL-40 Placebo
abciximab placebo; reteplase placebo, abciximab
Valsartan placebo + nateglinide placebo";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}