using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<mm>\b(?:1[0-2]|[1-9])\b)";
string input = @"1
2
3
4
5
6
7
8
9
10
11
12
13
some text with a 12 in it and a 13 also";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}