$re = '/(?P<mm>\b(?:1[0-2]|[1-9])\b)/m';
$str = '1
2
3
4
5
6
7
8
9
10
11
12
13
some text with a 12 in it and a 13 also';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);