// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<mm>\b(?:1[0-2]|[1-9])\b)").unwrap();
let string = "1
2
3
4
5
6
7
8
9
10
11
12
13
some text with a 12 in it and a 13 also";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}