use strict;
my $str = '1
2
3
4
5
6
7
8
9
10
11
12
13
some text with a 12 in it and a 13 also';
my $regex = qr/(?P<mm>\b(?:1[0-2]|[1-9])\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}