const regex = /(?P<mm>\b(?:1[0-2]|[1-9])\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<mm>\\b(?:1[0-2]|[1-9])\\b)', 'gm')
const str = `1
2
3
4
5
6
7
8
9
10
11
12
13
some text with a 12 in it and a 13 also`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}