using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+$ 7.000.000.000";
string input = @"end of string COINGBIT
0x18a0c976040e8fd9e529b8b363150b201606396e";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}